CVE-2014-9773

NameCVE-2014-9773
Descriptionmodules/chanserv/flags.c in Atheme before 7.2.7 allows remote attackers to modify the Anope FLAGS behavior by registering and dropping the (1) LIST, (2) CLEAR, or (3) MODIFY keyword nicks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
atheme-services (PTS)jessie (security), jessie6.0.11-2+deb8u1fixed
stretch7.2.9-1fixed
buster, sid7.2.9-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
atheme-servicessource(unstable)7.0.7-2medium
atheme-servicessourcejessie(not affected)

Notes

[jessie] - atheme-services <not-affected> (Vulnerable code introduced later)
https://github.com/atheme/atheme/issues/397
Fixed by: https://github.com/atheme/atheme/commit/c597156adc60a45b5f827793cd420945f47bc03b
Introduced in: https://github.com/atheme/atheme/commit/5c734f28068cf47b9b450af4dcf37195734b15be
http://www.openwall.com/lists/oss-security/2016/05/02/2

Search for package or bug name: Reporting problems