CVE-2014-9904

NameCVE-2014-9904
DescriptionThe snd_compress_check_input function in sound/core/compress_offload.c in the ALSA subsystem in the Linux kernel before 3.17 does not properly check for an integer overflow, which allows local users to cause a denial of service (insufficient memory allocation) or possibly have unspecified other impact via a crafted SNDRV_COMPRESS_SET_PARAMS ioctl call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3616-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1fixed
wheezy (security)3.2.96-2fixed
jessie3.16.51-2fixed
jessie (security)3.16.43-2+deb8u5fixed
stretch4.9.65-3fixed
stretch (security)4.9.30-2+deb9u5fixed
buster4.13.13-1fixed
sid4.14.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.0.2-1high
linuxsourcejessie3.16.7-ckt25-2+deb8u3highDSA-3616-1
linuxsourcewheezy(not affected)

Notes

[wheezy] - linux <not-affected> (Vulnerable code not present)
4.0.2-1 the first version in unstable after 3.17-rc1
Fixed by: https://git.kernel.org/linus/6217e5ede23285ddfee10d2e4ba0cc2d4c046205 (3.17-rc1)
Introduced by: https://git.kernel.org/linus/b35cc8225845112a616e3a2266d2fde5ab13d3ab (3.7-rc1)

Search for package or bug name: Reporting problems