CVE-2014-9913

NameCVE-2014-9913
DescriptionBuffer overflow in the list_files function in list.c in Info-Zip UnZip 6.0 allows remote attackers to cause a denial of service (crash) via vectors related to the compression method.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-741-1
NVD severitylow (attack range: local)
Debian Bugs847485

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unzip (PTS)jessie6.0-16+deb8u3fixed
jessie (security)6.0-16+deb8u2vulnerable
buster, sid, stretch6.0-21fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unzipsource(unstable)6.0-21low847485
unzipsourcejessie6.0-16+deb8u3low
unzipsourcewheezy6.0-8+deb7u6lowDLA-741-1

Notes

Upstream bug: http://www.info-zip.org/phpBB3/viewtopic.php?f=7&t=450
Same reproducer as in https://bugs.launchpad.net/ubuntu/+source/unzip/+bug/1643750
can be used to verify a fix (which trigger the issue in unzip -l but crash
in different areas of the unzip codebase)
http://www.openwall.com/lists/oss-security/2014/11/03/5

Search for package or bug name: Reporting problems