CVE-2015-0206

NameCVE-2015-0206
DescriptionMemory leak in the dtls1_buffer_record function in d1_pkt.c in OpenSSL 1.0.0 before 1.0.0p and 1.0.1 before 1.0.1k allows remote attackers to cause a denial of service (memory consumption) by sending many duplicate records for the next epoch, leading to failure of replay detection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3125-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)wheezy1.0.1e-2+deb7u20fixed
wheezy (security)1.0.1t-1+deb7u2fixed
jessie (security), jessie1.0.1t-1+deb8u6fixed
stretch1.1.0f-3fixed
buster, sid1.1.0f-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)1.0.1k-1medium
opensslsourcesqueeze(not affected)
opensslsourcewheezy1.0.1e-2+deb7u14mediumDSA-3125-1

Notes

[squeeze] - openssl <not-affected> (Affects 1.0.1 and 1.0.0)
https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=04685bc949e90a877656cf5020b6d4f90a9636a6

Search for package or bug name: Reporting problems