DescriptionApache WSS4J before 1.6.17 and 2.0.x before 2.0.2 improperly leaks information about decryption failures when decrypting an encrypted key or message data, which makes it easier for remote attackers to recover the plaintext form of a symmetric key via a series of crafted messages. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-2487.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs777741

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wss4j (PTS)jessie, stretch1.6.15-2fixed
buster, sid1.6.19-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wss4jsourcesqueeze(not affected)
wss4jsourcewheezy(not affected)


[wheezy] - wss4j <not-affected> (Vulnerable code not present)
[squeeze] - wss4j <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems