CVE-2015-0227

NameCVE-2015-0227
DescriptionApache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a vectors related to "wrapping attacks."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs777741

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wss4j (PTS)jessie, stretch1.6.15-2fixed
buster, sid1.6.19-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wss4jsource(unstable)1.6.15-2medium777741
wss4jsourcesqueeze(not affected)
wss4jsourcewheezy(not affected)

Notes

[wheezy] - wss4j <not-affected> (Vulnerable code not present)
[squeeze] - wss4j <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems