CVE-2015-0245

NameCVE-2015-0245
DescriptionD-Bus 1.4.x through 1.6.x before 1.6.30, 1.8.x before 1.8.16, and 1.9.x before 1.9.10 does not validate the source of ActivationFailure signals, which allows local users to cause a denial of service (activation failure error returned) by leveraging a race condition involving sending an ActivationFailure signal before systemd responds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3161-1
NVD severitylow (attack range: local)
Debian Bugs777545

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dbus (PTS)wheezy, wheezy (security)1.6.8-1+deb7u6fixed
jessie1.8.22-0+deb8u1fixed
stretch1.10.22-0+deb9u1fixed
buster1.11.20-1fixed
sid1.11.22-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dbussource(unstable)1.8.16-1low777545
dbussourcesqueeze(not affected)
dbussourcewheezy1.6.8-1+deb7u6lowDSA-3161-1

Notes

[squeeze] - dbus <not-affected> (affects 1.4 and above)

Search for package or bug name: Reporting problems