CVE-2015-0247

NameCVE-2015-0247
DescriptionHeap-based buffer overflow in openfs.c in the libext2fs library in e2fsprogs before 1.42.12 allows local users to execute arbitrary code via crafted block group descriptor data in a filesystem image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-153-1, DSA-3166-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
e2fsprogs (PTS)wheezy, wheezy (security)1.42.5-1.1+deb7u1fixed
jessie1.42.12-2fixed
stretch1.43.4-2fixed
buster1.43.6-1fixed
sid1.43.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
e2fsprogssource(unstable)1.42.12-1medium
e2fsprogssourcesqueeze1.41.12-4+deb6u1mediumDLA-153-1
e2fsprogssourcewheezy1.42.5-1.1+deb7u1mediumDSA-3166-1

Notes

https://git.kernel.org/cgit/fs/ext2/e2fsprogs.git/commit/?id=f66e6ce4

Search for package or bug name: Reporting problems