CVE-2015-0248

NameCVE-2015-0248
DescriptionThe (1) mod_dav_svn and (2) svnserve servers in Subversion 1.6.0 through 1.7.19 and 1.8.0 through 1.8.11 allow remote attackers to cause a denial of service (assertion failure and abort) via crafted parameter combinations related to dynamically evaluated revision numbers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-207-1, DSA-3231-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
subversion (PTS)wheezy1.6.17dfsg-4+deb7u10fixed
wheezy (security)1.6.17dfsg-4+deb7u12fixed
jessie1.8.10-6+deb8u4fixed
jessie (security)1.8.10-6+deb8u5fixed
stretch (security), stretch1.9.5-1+deb9u1fixed
buster, sid1.9.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
subversionsource(unstable)1.8.10-6medium
subversionsourcesqueeze1.6.12dfsg-7+deb6u2mediumDLA-207-1
subversionsourcewheezy1.6.17dfsg-4+deb7u9mediumDSA-3231-1

Notes

https://subversion.apache.org/security/CVE-2015-0248-advisory.txt

Search for package or bug name: Reporting problems