CVE-2015-0250

NameCVE-2015-0250
DescriptionXML external entity (XXE) vulnerability in the SVG to (1) PNG and (2) JPG conversion classes in Apache Batik 1.x before 1.8 allows remote attackers to read arbitrary files or cause a denial of service via a crafted SVG file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-182-1, DSA-3205-1
NVD severitymedium (attack range: remote)
Debian Bugs780897

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
batik (PTS)jessie1.7+dfsg-5fixed
jessie (security)1.7+dfsg-5+deb8u1fixed
stretch1.8-4fixed
stretch (security)1.8-4+deb9u1fixed
buster, sid1.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
batiksource(unstable)1.7+dfsg-5medium780897
batiksourcesqueeze1.7-6+deb6u1mediumDLA-182-1
batiksourcewheezy1.7+dfsg-3+deb7u1mediumDSA-3205-1

Notes

https://issues.apache.org/jira/browse/BATIK-1018
https://issues.apache.org/jira/browse/BATIK-1113
Commit disabling external xml entities: https://svn.apache.org/viewvc/xmlgraphics/batik/trunk/sources/org/apache/batik/dom/util/SAXDocumentFactory.java?r1=662304&r2=1664335&diff_format=h
PoC: https://www.ernw.de/download/xxe_batik.tar.xz

Search for package or bug name: Reporting problems