CVE-2015-0252

NameCVE-2015-0252
Descriptioninternal/XMLReader.cpp in Apache Xerces-C before 3.1.2 allows remote attackers to cause a denial of service (segmentation fault and crash) via crafted XML data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-181-1, DSA-3199-1
NVD severitymedium (attack range: remote)
Debian Bugs780827

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xerces-c (PTS)wheezy3.1.1-3+deb7u2fixed
wheezy (security)3.1.1-3+deb7u4fixed
jessie (security), jessie3.1.1-5.1+deb8u3fixed
buster, sid, stretch3.1.4+debian-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xerces-csource(unstable)3.1.1-5.1medium780827
xerces-csourcesqueeze3.1.1-1+deb6u1mediumDLA-181-1
xerces-csourcewheezy3.1.1-3+deb7u1mediumDSA-3199-1

Notes

http://svn.apache.org/viewvc?view=revision&revision=1667870

Search for package or bug name: Reporting problems