CVE-2015-0254

NameCVE-2015-0254
DescriptionApache Standard Taglibs before 1.2.3 allows remote attackers to execute arbitrary code or conduct external XML entity (XXE) attacks via a crafted XSLT extension in a (1) <x:parse> or (2) <x:transform> JSTL XML tag.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs779621

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jakarta-taglibs-standard (PTS)jessie1.1.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jakarta-taglibs-standardsource(unstable)1.1.2-3779621

Notes

[wheezy] - jakarta-taglibs-standard <no-dsa> (Minor issue)
https://bz.apache.org/bugzilla/show_bug.cgi?id=57560

Search for package or bug name: Reporting problems