CVE-2015-0282

NameCVE-2015-0282
DescriptionGnuTLS before 3.1.0 does not verify that the RSA PKCS #1 signature algorithm matches the signature algorithm in the certificate, which allows remote attackers to conduct downgrade attacks via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-180-1, DSA-3191-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls26 (PTS)wheezy, wheezy (security)2.12.20-8+deb7u5fixed
gnutls28 (PTS)jessie3.3.8-6+deb8u7fixed
jessie (security)3.3.8-6+deb8u6fixed
stretch3.5.8-5+deb9u3fixed
stretch (security)3.5.8-5+deb9u1fixed
buster, sid3.5.15-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls26source(unstable)(unfixed)medium
gnutls26sourcesqueeze2.8.6-1+squeeze5mediumDLA-180-1
gnutls26sourcewheezy2.12.20-8+deb7u3mediumDSA-3191-1
gnutls28source(unstable)(not affected)

Notes

- gnutls28 <not-affected> (Fixed in 3.1.0)
http://www.gnutls.org/security.html#GNUTLS-SA-2015-1

Search for package or bug name: Reporting problems