CVE-2015-0778

NameCVE-2015-0778
Descriptionosc before 0.151.0 allows remote attackers to execute arbitrary commands via shell metacharacters in a _service file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs780410

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
osc (PTS)buster0.164.2-1fixed
bookworm, sid, bullseye0.169.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
oscsourcewheezy0.134.1-2+deb7u1
oscsource(unstable)0.149.0-2low780410

Notes

[squeeze] - osc <no-dsa> (Minor issue)
https://bugzilla.suse.com/show_bug.cgi?id=901643

Search for package or bug name: Reporting problems