CVE-2015-0838

NameCVE-2015-0838
DescriptionBuffer overflow in the C implementation of the apply_delta function in _pack.c in Dulwich before 0.9.9 allows remote attackers to execute arbitrary code via a crafted pack file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-231-1, DSA-3206-1
NVD severityhigh (attack range: remote)
Debian Bugs780958

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dulwich (PTS)wheezy, wheezy (security)0.8.5-2+deb7u2fixed
jessie0.9.7-3fixed
stretch0.16.3-1fixed
buster, sid0.18.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dulwichsource(unstable)0.10.1-1high780958
dulwichsourcejessie0.9.7-3high
dulwichsourcesqueeze0.6.1-1+deb6u1highDLA-231-1
dulwichsourcewheezy0.8.5-2+deb7u2highDSA-3206-1

Search for package or bug name: Reporting problems