CVE-2015-0886

NameCVE-2015-0886
DescriptionInteger overflow in the crypt_raw method in the key-stretching implementation in jBCrypt before 0.4 makes it easier for remote attackers to determine cleartext values of password hashes via a brute-force attack against hashes associated with the maximum exponent.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs780102

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libjbcrypt-java (PTS)buster, stretch0.4-2fixed
bookworm, sid, bullseye0.4-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libjbcrypt-javasource(unstable)0.4-1780102

Notes

[jessie] - libjbcrypt-java <no-dsa> (Minor issue)
[wheezy] - libjbcrypt-java <no-dsa> (Minor issue)
[squeeze] - libjbcrypt-java <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems