CVE-2015-0971

NameCVE-2015-0971
DescriptionThe DER parser in Suricata before 2.0.8 allows remote attackers to cause a denial of service (crash) via vectors related to SSL/TLS certificates.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3254-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
suricata (PTS)wheezy1.2.1-2fixed
wheezy (security)1.2.1-2+deb7u1fixed
jessie (security), jessie2.0.7-2+deb8u1fixed
stretch3.2.1-1+deb9u1fixed
buster1:4.0.1-2fixed
sid1:4.0.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
suricatasource(unstable)2.0.8-1medium
suricatasourcejessie2.0.7-2+deb8u1mediumDSA-3254-1
suricatasourcesqueeze(not affected)
suricatasourcewheezy(not affected)

Notes

[wheezy] - suricata <not-affected> (ASN.1 parser for X509 certificates in DER format introduced in 1.3)
[squeeze] - suricata <not-affected> (ASN.1 parser for X509 certificates in DER format introduced in 1.3)
http://suricata-ids.org/2015/05/06/suricata-2-0-8-available/
Patch: https://github.com/inliniac/suricata/commit/fa73a0bb8f312fd0a95cc70f6b3ee4e4997bdba7

Search for package or bug name: Reporting problems