CVE-2015-1027

NameCVE-2015-1027
DescriptionThe version checking subroutine in percona-toolkit before 2.2.13 and xtrabackup before 2.2.9 was vulnerable to silent HTTP downgrade attacks and Man In The Middle attacks in which the server response could be modified to allow the attacker to respond with modified command payload and have the client return additional running configuration information leading to an information disclosure of running configuration of MySQL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
percona-toolkit (PTS)jessie2.2.11-1~dfsg1vulnerable
stretch2.2.20-1fixed
buster3.0.11-1fixed
sid3.0.12-1fixed
percona-xtrabackup (PTS)sid, jessie2.2.3-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
percona-toolkitsource(unstable)2.2.13-1unimportant
percona-toolkitsourcewheezy(not affected)
percona-xtrabackupsource(unstable)(unfixed)unimportant

Notes

[wheezy] - percona-toolkit <not-affected> (version-check introduced in 2.1.4)
Automatic version check is disabled and inherently insecure (CVE-2014-2029)
Patch applied to OpenSUSE 13.1: https://build.opensuse.org/package/view_file/openSUSE:13.1:Update/xtrabackup/percona-xtrabackup-CVE-2015-1027.patch?expand=1

Search for package or bug name: Reporting problems