CVE-2015-1029

NameCVE-2015-1029
DescriptionThe puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs775535

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet-module-puppetlabs-stdlib (PTS)stretch4.14.0-1fixed
buster, bookworm, bullseye, sid5.0.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppet-module-puppetlabs-stdlibsourcejessie(not affected)
puppet-module-puppetlabs-stdlibsource(unstable)4.9.0-1775535

Notes

[jessie] - puppet-module-puppetlabs-stdlib <not-affected> (The jessie version of facter is recent enough)
http://puppetlabs.com/security/cve/cve-2015-1029
http://lists.alioth.debian.org/pipermail/pkg-puppet-devel/2015-January/009318.html

Search for package or bug name: Reporting problems