CVE-2015-1038

NameCVE-2015-1038
Descriptionp7zip 9.20.1 allows remote attackers to write to arbitrary files via a symlink attack in an archive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-245-1, DSA-3289-1
NVD severitymedium (attack range: remote)
Debian Bugs774660

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
p7zip (PTS)wheezy9.20.1~dfsg.1-4+deb7u1fixed
wheezy (security)9.20.1~dfsg.1-4+deb7u2fixed
jessie (security), jessie9.20.1~dfsg.1-4.1+deb8u2fixed
stretch16.02+dfsg-3fixed
buster, sid16.02+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
p7zipsource(unstable)9.20.1~dfsg.1-4.2medium774660
p7zipsourcejessie9.20.1~dfsg.1-4.1+deb8u1mediumDSA-3289-1
p7zipsourcesqueeze9.04~dfsg.1-1+deb6u1mediumDLA-245-1
p7zipsourcewheezy9.20.1~dfsg.1-4+deb7u1mediumDSA-3289-1

Notes

Upstream bug: http://sourceforge.net/p/p7zip/bugs/147/

Search for package or bug name: Reporting problems