CVE-2015-1159

NameCVE-2015-1159
DescriptionCross-site scripting (XSS) vulnerability in the cgi_puts function in cgi-bin/template.c in the template engine in CUPS before 2.0.3 allows remote attackers to inject arbitrary web script or HTML via the QUERY parameter to help/.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-239-1, DSA-3283-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)jessie1.7.5-11+deb8u2fixed
jessie (security)1.7.5-11+deb8u6fixed
stretch2.2.1-8+deb9u4fixed
stretch (security)2.2.1-8+deb9u2fixed
buster2.2.10-6+deb10u1fixed
bullseye, sid2.3.0-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssource(unstable)1.7.5-12
cupssourcejessie1.7.5-11+deb8u1DSA-3283-1
cupssourcesqueeze1.4.4-7+squeeze8DLA-239-1
cupssourcewheezy1.5.3-5+deb7u6DSA-3283-1

Search for package or bug name: Reporting problems