CVE-2015-1196

NameCVE-2015-1196
DescriptionGNU patch 2.7.1 allows remote attackers to write to arbitrary files via a symlink attack in a patch file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs775227

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
patch (PTS)buster, buster (security)2.7.6-3+deb10u1fixed
bookworm, sid, bullseye2.7.6-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
patchsourcesqueeze(not affected)
patchsourcewheezy(not affected)
patchsource(unstable)2.7.1-7775227

Notes

[wheezy] - patch <not-affected> (Support for git-style patches added in 2.7)
[squeeze] - patch <not-affected> (Support for git-style patches added in 2.7)

Search for package or bug name: Reporting problems