CVE-2015-1258

NameCVE-2015-1258
DescriptionGoogle Chrome before 43.0.2357.65 relies on libvpx code that was not built with an appropriate --size-limit value, which allows remote attackers to trigger a negative value for a size field, and consequently cause a denial of service or possibly have unspecified other impact, via a crafted frame size in VP9 video data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3267-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvpx (PTS)buster1.7.0-3+deb10u1fixed
buster (security)1.7.0-3+deb10u2fixed
bullseye (security), bullseye1.9.0-1+deb11u2fixed
bookworm, bookworm (security)1.12.0-1+deb12u2fixed
sid, trixie1.14.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersourcewheezy(unfixed)end-of-life
chromium-browsersourcejessie43.0.2357.65-1~deb8u1DSA-3267-1
chromium-browsersource(unstable)43.0.2357.65-1
libvpxsourcesqueeze(not affected)
libvpxsourcewheezy(not affected)
libvpxsource(unstable)1.4.0-4unimportant

Notes

[wheezy] - libvpx <not-affected> (vp9 code introduced in 1.3.0)
[squeeze] - libvpx <not-affected> (vp9 code not present in 0.9.1)
That's not a vulnerability in libvpx per se
1.4.0-4 adds the workaround to configure with --size-limit=16384x16384
https://github.com/webmproject/libvpx/commit/943e43273b0a7369d07714e7fd2e19fecfb11c7c

Search for package or bug name: Reporting problems