CVE-2015-1283

NameCVE-2015-1283
DescriptionMultiple integer overflows in the XML_GetBuffer function in Expat through 2.1.0, as used in Google Chrome before 44.0.2403.89 and other products, allow remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via crafted XML data, a related issue to CVE-2015-2716.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-281-1, DSA-3315-1, DSA-3318-1
NVD severitymedium (attack range: remote)
Debian Bugs793484

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)wheezy, wheezy (security)37.0.2062.120-1~deb7u1vulnerable
jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch62.0.3202.89-1~deb9u1fixed
stretch (security)63.0.3239.84-1~deb9u1fixed
buster62.0.3202.89-1fixed
sid63.0.3239.84-1fixed
expat (PTS)wheezy2.1.0-1+deb7u2fixed
wheezy (security)2.1.0-1+deb7u5fixed
jessie (security), jessie2.1.0-6+deb8u4fixed
stretch (security), stretch2.2.0-2+deb9u1fixed
buster, sid2.2.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)44.0.2403.89-1medium
chromium-browsersourcejessie44.0.2403.89-1~deb8u1mediumDSA-3315-1
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersourcewheezy(unfixed)end-of-life
expatsource(unstable)2.1.0-7medium793484
expatsourcejessie2.1.0-6+deb8u1mediumDSA-3318-1
expatsourcesqueeze2.0.1-7+squeeze2mediumDLA-281-1
expatsourcewheezy2.1.0-1+deb7u2mediumDSA-3318-1

Notes

Patch: https://hg.mozilla.org/releases/mozilla-esr31/rev/2f3e78643f5c

Search for package or bug name: Reporting problems