CVE-2015-1315

NameCVE-2015-1315
DescriptionBuffer overflow in the charset_to_intern function in unix/unix.c in Info-Zip UnZip 6.10b allows remote attackers to execute arbitrary code via a crafted string, as demonstrated by converting a string from CP866 to UTF-8.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unzip (PTS)stretch6.0-21+deb9u2fixed
buster6.0-23+deb10u1fixed
bullseye, sid6.0-25fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unzipsource(unstable)(not affected)

Notes

- unzip <not-affected> (*-unzip60-alt-iconv-utf8 patch not applied in Debian)

Search for package or bug name: Reporting problems