CVE-2015-1331

NameCVE-2015-1331
Descriptionlxclock.c in LXC 1.1.2 and earlier allows local users to create arbitrary files via a symlink attack on /run/lock/lxc/*.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3317-1
Debian Bugs793298

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lxc (PTS)buster1:3.1.0+really3.0.3-8fixed
bullseye1:4.0.6-2+deb11u1fixed
bookworm, sid1:5.0.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lxcsourcesqueeze(not affected)
lxcsourcewheezy(not affected)
lxcsourcejessie1:1.0.6-6+deb8u1DSA-3317-1
lxcsource(unstable)1:1.0.7-4793298

Notes

[wheezy] - lxc <not-affected> (Affects 1.0.0 and higher)
[squeeze] - lxc <not-affected> (Affects 1.0.0 and higher)

Search for package or bug name: Reporting problems