CVE-2015-1334

NameCVE-2015-1334
Descriptionattach.c in LXC 1.1.2 and earlier uses the proc filesystem in a container, which allows local container users to escape AppArmor or SELinux confinement by mounting a proc filesystem with a crafted (1) AppArmor profile or (2) SELinux label.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3317-1
NVD severitymedium (attack range: local)
Debian Bugs793298

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lxc (PTS)wheezy0.8.0~rc1-8+deb7u2fixed
jessie1:1.0.6-6+deb8u6fixed
jessie (security)1:1.0.6-6+deb8u2fixed
stretch1:2.0.7-2+deb9u1fixed
buster, sid1:2.0.9-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lxcsource(unstable)1:1.0.7-4medium793298
lxcsourcejessie1:1.0.6-6+deb8u1mediumDSA-3317-1
lxcsourcesqueeze(not affected)
lxcsourcewheezy(not affected)

Notes

[wheezy] - lxc <not-affected> (Affects 0.9.0 and higher)
[squeeze] - lxc <not-affected> (Affects 0.9.0 and higher)

Search for package or bug name: Reporting problems