CVE-2015-1335

NameCVE-2015-1335
Descriptionlxc-start in lxc before 1.0.8 and 1.1.x before 1.1.4 allows local container administrators to escape AppArmor confinement via a symlink attack on a (1) mount target or (2) bind mount source.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-442-1, DSA-3400-1
NVD severityhigh (attack range: local)
Debian Bugs800471

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lxc (PTS)wheezy0.8.0~rc1-8+deb7u2vulnerable
jessie1:1.0.6-6+deb8u6fixed
jessie (security)1:1.0.6-6+deb8u2fixed
stretch1:2.0.7-2fixed
buster1:2.0.8-2fixed
sid1:2.0.8-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lxcsource(unstable)1:1.0.8-1high800471
lxcsourcejessie1:1.0.6-6+deb8u2highDSA-3400-1
lxcsourcesqueeze0.7.2-1+deb6u1highDLA-442-1

Notes

[wheezy] - lxc <no-dsa> (Minor issue)
https://launchpad.net/bugs/1476662
https://github.com/lxc/lxc/commit/592fd47a6245508b79fe6ac819fe6d3b2c1289be
https://lists.linuxcontainers.org/pipermail/lxc-devel/2015-September/012434.html

Search for package or bug name: Reporting problems