CVE-2015-1349

NameCVE-2015-1349
Descriptionnamed in ISC BIND 9.7.0 through 9.9.6 before 9.9.6-P2 and 9.10.x before 9.10.1-P2, when DNSSEC validation and the managed-keys feature are enabled, allows remote attackers to cause a denial of service (assertion failure and daemon exit, or daemon crash) by triggering an incorrect trust-anchor management scenario in which no key is ready for use.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-163-1, DSA-3162-1
NVD severitymedium (attack range: remote)
Debian Bugs778733

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bind9 (PTS)wheezy1:9.8.4.dfsg.P1-6+nmu2+deb7u10fixed
wheezy (security)1:9.8.4.dfsg.P1-6+nmu2+deb7u18fixed
jessie1:9.9.5.dfsg-9+deb8u12fixed
jessie (security)1:9.9.5.dfsg-9+deb8u13fixed
stretch1:9.10.3.dfsg.P4-12.3+deb9u3fixed
stretch (security)1:9.10.3.dfsg.P4-12.3+deb9u2fixed
buster1:9.10.3.dfsg.P4-12.6fixed
sid1:9.10.6+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bind9source(unstable)1:9.9.5.dfsg-9low778733
bind9sourcesqueeze1:9.7.3.dfsg-1~squeeze14mediumDLA-163-1
bind9sourcewheezy1:9.8.4.dfsg.P1-6+nmu2+deb7u4mediumDSA-3162-1

Search for package or bug name: Reporting problems