CVE-2015-1381

NameCVE-2015-1381
DescriptionMultiple unspecified vulnerabilities in pcrs.c in Privoxy before 3.0.23 allow remote attackers to cause a denial of service (segmentation fault or memory consumption) via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-142-1, DSA-3145-1
NVD severitymedium (attack range: remote)
Debian Bugs776490

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
privoxy (PTS)wheezy, wheezy (security)3.0.19-2+deb7u3fixed
jessie (security), jessie3.0.21-7+deb8u1fixed
stretch3.0.26-3fixed
buster, sid3.0.26-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
privoxysource(unstable)3.0.21-7medium776490
privoxysourcesqueeze3.0.16-1+deb6u1mediumDLA-142-1
privoxysourcewheezy3.0.19-2+deb7u2mediumDSA-3145-1

Notes

http://ijbswa.cvs.sourceforge.net/viewvc/ijbswa/current/pcrs.c?r1=1.46&r2=1.47

Search for package or bug name: Reporting problems