CVE-2015-1382

NameCVE-2015-1382
Descriptionparsers.c in Privoxy before 3.0.23 allows remote attackers to cause a denial of service (invalid read and crash) via vectors related to an HTTP time header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-142-1, DSA-3145-1
NVD severitymedium (attack range: remote)
Debian Bugs776490

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
privoxy (PTS)wheezy, wheezy (security)3.0.19-2+deb7u3fixed
jessie (security), jessie3.0.21-7+deb8u1fixed
buster, sid, stretch3.0.26-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
privoxysource(unstable)3.0.21-7medium776490
privoxysourcesqueeze3.0.16-1+deb6u1mediumDLA-142-1
privoxysourcewheezy3.0.19-2+deb7u2mediumDSA-3145-1

Notes

http://ijbswa.cvs.sourceforge.net/viewvc/ijbswa/current/parsers.c?r1=1.297&r2=1.298

Search for package or bug name: Reporting problems