CVE-2015-1395

NameCVE-2015-1395
DescriptionDirectory traversal vulnerability in GNU patch versions which support Git-style patching before 2.7.3 allows remote attackers to write to arbitrary files with the permissions of the target user via a .. (dot dot) in a diff file name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs775873

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
patch (PTS)buster, buster (security)2.7.6-3+deb10u1fixed
trixie, sid, bookworm, bullseye2.7.6-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
patchsourcesqueeze(not affected)
patchsourcewheezy(not affected)
patchsource(unstable)2.7.3-1775873

Notes

[wheezy] - patch <not-affected> (Support for git-style patches added in 2.7)
[squeeze] - patch <not-affected> (Support for git-style patches added in 2.7)
Upstream report: https://savannah.gnu.org/bugs/?44059
https://www.openwall.com/lists/oss-security/2015/01/24/2

Search for package or bug name: Reporting problems