CVE-2015-1396

NameCVE-2015-1396
DescriptionA Directory Traversal vulnerability exists in the GNU patch before 2.7.4. A remote attacker can write to arbitrary files via a symlink attack in a patch file. NOTE: this issue exists because of an incomplete fix for CVE-2015-1196.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs775901

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
patch (PTS)stretch (security), stretch2.7.5-1+deb9u2fixed
buster, buster (security)2.7.6-3+deb10u1fixed
bullseye, sid2.7.6-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
patchsourcesqueeze(not affected)
patchsourcewheezy(not affected)
patchsource(unstable)2.7.3-1775901

Notes

[wheezy] - patch <not-affected> (Not affected by CVE-2015-1196 and no incomplete fix applied)
[squeeze] - patch <not-affected> (Not affected by CVE-2015-1196 and no incomplete fix applied)
https://www.openwall.com/lists/oss-security/2015/01/24/3

Search for package or bug name: Reporting problems