CVE-2015-1426

NameCVE-2015-1426
DescriptionPuppet Labs Facter 1.6.0 through 2.4.0 allows local users to obtains sensitive Amazon EC2 IAM instance metadata by reading a fact for an Amazon EC2 node.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)
Debian Bugs778265

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
facter (PTS)jessie2.2.0-1vulnerable
stretch2.4.6-1fixed
buster, sid3.11.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
factersource(unstable)2.4.4-1low778265
factersourcesqueeze(not affected)

Notes

[jessie] - facter <no-dsa> (Minor issue)
[squeeze] - facter <not-affected> (Uses version 2008-02-01 of the EC2 API which does not expose security credentials)
[wheezy] - facter <no-dsa> (Minor issue)
http://puppetlabs.com/security/cve/cve-2015-1426
https://tickets.puppetlabs.com/browse/FACT-800
The assessment for Squeeze being unaffected is based on the fact that the code accesses http://169.254.169.254/2008-02-01/meta-data/ and that http://docs.aws.amazon.com/AWSEC2/latest/UserGuide/ec2-instance-metadata.html mentions the iam/security-credentials/role key as being introduced in version 2012-01-12.

Search for package or bug name: Reporting problems