CVE-2015-1546

NameCVE-2015-1546
DescriptionDouble free vulnerability in the get_vrFilter function in servers/slapd/filter.c in OpenLDAP 2.4.40 allows remote attackers to cause a denial of service (crash) via a crafted search query with a matched values control.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs776991

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openldap (PTS)stretch2.4.44+dfsg-5+deb9u4fixed
stretch (security)2.4.44+dfsg-5+deb9u9fixed
buster2.4.47+dfsg-3+deb10u6fixed
buster (security)2.4.47+dfsg-3+deb10u7fixed
bullseye2.4.57+dfsg-3fixed
bullseye (security)2.4.57+dfsg-3+deb11u1fixed
bookworm, sid2.5.12+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openldapsourcesqueeze(not affected)
openldapsourcewheezy(not affected)
openldapsource(unstable)2.4.40-4776991

Notes

[wheezy] - openldap <not-affected> (Regression introduced in 2.4.40)
[squeeze] - openldap <not-affected> (Regression introduced in 2.4.40)
http://www.openldap.org/its/?findid=8046
http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commitdiff;h=2f1a2dd329b91afe561cd06b872d09630d4edb6a

Search for package or bug name: Reporting problems