CVE-2015-1558

NameCVE-2015-1558
DescriptionAsterisk Open Source 12.x before 12.8.1 and 13.x before 13.1.1, when using the PJSIP channel driver, does not properly reclaim RTP ports, which allows remote authenticated users to cause a denial of service (file descriptor consumption) via an SDP offer containing only incompatible codecs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs780601

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)buster1:16.2.1~dfsg-1+deb10u2fixed
buster (security)1:16.28.0~dfsg-0+deb10u1fixed
bullseye1:16.16.1~dfsg-1+deb11u1fixed
bullseye (security)1:16.28.0~dfsg-0+deb11u1fixed
sid, bookworm1:20.0.0~dfsg+~cs6.12.40431414-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksourcesqueeze(not affected)
asterisksourcewheezy(not affected)
asterisksourcejessie(not affected)
asterisksource(unstable)1:13.1.0~dfsg-1.1780601

Notes

[jessie] - asterisk <not-affected> (Only affects 12.x and 13.x)
[wheezy] - asterisk <not-affected> (Only affects 12.x and 13.x)
[squeeze] - asterisk <not-affected> (Only affects 12.x and 13.x)
https://issues.asterisk.org/jira/browse/ASTERISK-24666
http://downloads.digium.com/pub/security/AST-2015-001.html

Search for package or bug name: Reporting problems