CVE-2015-1589

NameCVE-2015-1589
DescriptionDirectory traversal vulnerability in arCHMage 0.2.4 allows remote attackers to write to arbitrary files via a .. (dot dot) in a CHM file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs776164

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
archmage (PTS)stretch1:0.3.1-3fixed
buster1:0.3.1-4fixed
bullseye1:0.4.2.1-1fixed
bookworm, sid1:0.4.2.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
archmagesource(unstable)1:0.2.4-4776164

Notes

[squeeze] - archmage <no-dsa> (Minor issue)
[wheezy] - archmage <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2015/02/12/9

Search for package or bug name: Reporting problems