CVE-2015-1609

NameCVE-2015-1609
DescriptionMongoDB before 2.4.13 and 2.6.x before 2.6.8 allows remote attackers to cause a denial of service via a crafted UTF-8 string in a BSON request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs780129

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mongodb (PTS)jessie1:2.4.10-5+deb8u1fixed
stretch1:3.2.11-2+deb9u1fixed
buster, sid1:3.4.15-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mongodbsource(unstable)1:2.4.10-5medium780129
mongodbsourcesqueeze(not affected)
mongodbsourcewheezy(not affected)

Notes

[wheezy] - mongodb <not-affected> (BSONElement::validate() checks length, problematic code introduced later)
[squeeze] - mongodb <not-affected> (BSONElement::validate() checks length (db/jsobj.cpp +589))
https://jira.mongodb.org/browse/SERVER-17264
Fast bson validate introduced with https://github.com/mongodb/mongo/commit/6889d1658136c753998b4a408dc8d1a3ec28e3b9 (r2.3.2)

Search for package or bug name: Reporting problems