CVE-2015-1781

NameCVE-2015-1781
DescriptionA buffer overflow flaw was found in the way glibc's gethostbyname_r() and other related functions computed the size of a buffer when passed a misaligned buffer as input. An attacker able to make an application call any of these functions with a misaligned buffer could use this flaw to crash the application or, potentially, execute arbitrary code with the permissions of the user running the application.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-230-1, DSA-3480-1
Debian Bugs796105

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glibc (PTS)buster2.28-10+deb10u1fixed
buster (security)2.28-10+deb10u2fixed
bullseye2.31-13+deb11u5fixed
bookworm, sid2.36-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsourcesqueeze2.11.3-4+deb6u6DLA-230-1
eglibcsourcewheezy2.13-38+deb7u10DSA-3480-1
eglibcsource(unstable)(unfixed)
glibcsourceexperimental2.21-0experimental1
glibcsourcejessie2.19-18+deb8u1
glibcsource(unstable)2.19-20796105

Notes

https://sourceware.org/bugzilla/show_bug.cgi?id=18287
Upstream commit: https://sourceware.org/git/?p=glibc.git;a=commit;h=2959eda9272a03386

Search for package or bug name: Reporting problems