CVE-2015-1817

NameCVE-2015-1817
DescriptionStack-based buffer overflow in the inet_pton function in network/inet_pton.c in musl libc 0.9.15 through 1.0.4, and 1.1.0 through 1.1.7 allows attackers to have unspecified impact via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs781497

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
musl (PTS)stretch1.1.16-3fixed
stretch (security)1.1.16-3+deb9u1fixed
buster1.1.21-2fixed
bullseye, sid1.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
muslsource(unstable)1.1.5-2781497

Search for package or bug name: Reporting problems