CVE-2015-1821

NameCVE-2015-1821
DescriptionHeap-based buffer overflow in chrony before 1.31.1 allows remote authenticated users to cause a denial of service (chronyd crash) or possibly execute arbitrary code by configuring the (1) NTP or (2) cmdmon access with a subnet size that is indivisible by four and an address with a nonzero bit in the subnet remainder.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-193-1, DSA-3222-1
NVD severitymedium (attack range: remote)
Debian Bugs782160

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chrony (PTS)wheezy1.24-3.1+deb7u3fixed
wheezy (security)1.24-3.1+deb7u4fixed
jessie1.30-2+deb8u2fixed
stretch3.0-4+deb9u1fixed
buster, sid3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chronysource(unstable)1.30-2medium782160
chronysourcesqueeze1.24-3+squeeze2mediumDLA-193-1
chronysourcewheezy1.24-3.1+deb7u3mediumDSA-3222-1

Notes

Fix: http://git.tuxfamily.org/chrony/chrony.git/commit/?h=1.31-security&id=cf19042ecb656b8afec0cc4906e7dd3ea9266ac8

Search for package or bug name: Reporting problems