CVE-2015-1833

NameCVE-2015-1833
DescriptionXML external entity (XXE) vulnerability in Apache Jackrabbit before 2.0.6, 2.2.x before 2.2.14, 2.4.x before 2.4.6, 2.6.x before 2.6.6, 2.8.x before 2.8.1, and 2.10.x before 2.10.1 allows remote attackers to read arbitrary files and send requests to intranet servers via a crafted WebDAV request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3298-1
NVD severitymedium (attack range: remote)
Debian Bugs787316

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jackrabbit (PTS)wheezy2.3.6-1+deb7u1fixed
wheezy (security)2.3.6-1+deb7u2fixed
jessie (security), jessie2.3.6-1+deb8u2fixed
buster, sid, stretch2.12.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jackrabbitsource(unstable)2.10.1-1medium787316
jackrabbitsourcejessie2.3.6-1+deb8u1mediumDSA-3298-1
jackrabbitsourcewheezy2.3.6-1+deb7u1mediumDSA-3298-1

Notes

https://issues.apache.org/jira/browse/JCR-3883

Search for package or bug name: Reporting problems