CVE-2015-1853

NameCVE-2015-1853
Descriptionchrony before 1.31.1 does not properly protect state variables in authenticated symmetric NTP associations, which allows remote attackers with knowledge of NTP peering to cause a denial of service (inability to synchronize) via random timestamps in crafted NTP data packets.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-193-1, DSA-3222-1
NVD severitymedium
Debian Bugs782160

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chrony (PTS)stretch3.0-4+deb9u2fixed
buster3.4-4+deb10u1fixed
bullseye, sid3.5.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chronysourcesqueeze1.24-3+squeeze2DLA-193-1
chronysourcewheezy1.24-3.1+deb7u3DSA-3222-1
chronysource(unstable)1.30-2782160

Notes

Fix: http://git.tuxfamily.org/chrony/chrony.git/commit/?h=1.31-security&id=d856bd34c4862398411d29200520e3a3b1d4569e

Search for package or bug name: Reporting problems