CVE-2015-1856

NameCVE-2015-1856
DescriptionOpenStack Object Storage (Swift) before 2.3.0, when allow_version is configured, allows remote authenticated users to delete the latest version of an object by leveraging listing access to the x-versions-location container.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs783163

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
swift (PTS)buster2.19.1-1fixed
buster (security)2.19.1-1+deb10u1fixed
bullseye (security), bullseye2.26.0-10+deb11u1fixed
bookworm2.30.0-4fixed
trixie2.33.0-4fixed
sid2.33.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
swiftsourcejessie2.2.0-1+deb8u1
swiftsource(unstable)2.2.0-2783163

Notes

[wheezy] - swift <no-dsa> (Minor issue)
https://launchpad.net/bugs/1430645

Search for package or bug name: Reporting problems