CVE-2015-1858

NameCVE-2015-1858
DescriptionMultiple buffer overflows in gui/image/qbmphandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted BMP image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-210-1
NVD severitymedium (attack range: remote)
Debian Bugs783133, 783134

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)wheezy4:4.8.2+dfsg-11vulnerable
jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
buster, stretch, sid4:4.8.7+dfsg-11fixed
qtbase-opensource-src (PTS)jessie5.3.2+dfsg-4+deb8u2fixed
stretch5.7.1+dfsg-3fixed
buster5.9.1+dfsg-9fixed
sid5.9.1+dfsg-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt4-x11source(unstable)4:4.8.6+git155-g716fbae+dfsg-2medium783133
qt4-x11sourcejessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1medium
qt4-x11sourcesqueeze4:4.6.3-4+squeeze3mediumDLA-210-1
qtbase-opensource-srcsource(unstable)5.3.2+dfsg-5medium783134
qtbase-opensource-srcsourcejessie5.3.2+dfsg-4+deb8u1medium

Notes

[wheezy] - qt4-x11 <no-dsa> (Minor issue)
http://lists.qt-project.org/pipermail/announce/2015-April/000067.html

Search for package or bug name: Reporting problems