CVE-2015-1860

NameCVE-2015-1860
DescriptionMultiple buffer overflows in gui/image/qgifhandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a crafted GIF image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-210-1
NVD severitymedium
Debian Bugs783133, 783134

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)stretch4:4.8.7+dfsg-11fixed
stretch (security)4:4.8.7+dfsg-11+deb9u1fixed
buster4:4.8.7+dfsg-18+deb10u1fixed
qtbase-opensource-src (PTS)stretch5.7.1+dfsg-3+deb9u2fixed
stretch (security)5.7.1+dfsg-3+deb9u3fixed
buster5.11.3+dfsg1-1+deb10u4fixed
buster (security)5.11.3+dfsg1-1+deb10u3fixed
bullseye, sid5.15.1+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt4-x11sourcesqueeze4:4.6.3-4+squeeze3DLA-210-1
qt4-x11sourcejessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
qt4-x11source(unstable)4:4.8.6+git155-g716fbae+dfsg-2783133
qtbase-opensource-srcsourcejessie5.3.2+dfsg-4+deb8u1
qtbase-opensource-srcsource(unstable)5.3.2+dfsg-5783134

Notes

[wheezy] - qt4-x11 <no-dsa> (Minor issue)
http://lists.qt-project.org/pipermail/announce/2015-April/000067.html

Search for package or bug name: Reporting problems