CVE-2015-1863

NameCVE-2015-1863
DescriptionHeap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (crash), read memory, or possibly execute arbitrary code via crafted SSID information in a management frame when creating or updating P2P entries.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3233-1
NVD severitymedium (attack range: remote)
Debian Bugs783148

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)wheezy1.0-3+deb7u3fixed
wheezy (security)1.0-3+deb7u4fixed
jessie2.3-1+deb8u4fixed
jessie (security)2.3-1+deb8u5fixed
stretch2:2.4-1fixed
stretch (security)2:2.4-1+deb9u1fixed
buster, sid2:2.4-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasource(unstable)2.3-2medium783148
wpasourcejessie2.3-1+deb8u1mediumDSA-3233-1
wpasourcewheezy1.0-3+deb7u2mediumDSA-3233-1
wpasupplicantsource(unstable)(not affected)

Notes

- wpasupplicant <not-affected> (Vulnerable code present since v1.0)
http://w1.fi/security/2015-1/
Vulnerable are v1.0-v2.4 with CONFIG_P2P build option enabled
CONFIG_P2P enabled since 1.1-1 in debian/config/wpasupplicant/linux
Binary packages built for wheezy are not affected since WiFi P2P is disabled

Search for package or bug name: Reporting problems