DescriptionHeap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (crash), read memory, or possibly execute arbitrary code via crafted SSID information in a management frame when creating or updating P2P entries.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs783148

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)jessie2.3-1+deb8u5fixed
jessie (security)2.3-1+deb8u6fixed
stretch (security), stretch2:2.4-1+deb9u1fixed
buster, sid2:2.6-18fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasupplicantsource(unstable)(not affected)


- wpasupplicant <not-affected> (Vulnerable code present since v1.0)
Vulnerable are v1.0-v2.4 with CONFIG_P2P build option enabled
CONFIG_P2P enabled since 1.1-1 in debian/config/wpasupplicant/linux
Binary packages built for wheezy are not affected since WiFi P2P is disabled

Search for package or bug name: Reporting problems