CVE-2015-2045

NameCVE-2015-2045
DescriptionThe HYPERVISOR_xen_version hypercall in Xen 3.2.x through 4.5.x does not properly initialize data structures, which allows local guest users to obtain sensitive information via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3181-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-8fixed
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch4.8.1-1+deb9u1fixed
stretch (security)4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.4.1-8low
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.4-3+deb7u5lowDSA-3181-1

Notes

[squeeze] - xen <end-of-life> (Unsupported in squeeze-lts)
http://xenbits.xen.org/xsa/advisory-122.html

Search for package or bug name: Reporting problems