CVE-2015-2091

NameCVE-2015-2091
DescriptionThe authentication hook (mgs_hook_authz) in mod-gnutls 0.5.10 and earlier does not validate client certificates when "GnuTLSClientVerify require" is set, which allows remote attackers to spoof clients via a crafted certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-170-1, DSA-3177-1
NVD severitymedium (attack range: remote)
Debian Bugs578663

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mod-gnutls (PTS)wheezy, wheezy (security)0.5.10-1.1+deb7u1fixed
buster, sid, stretch0.8.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mod-gnutlssource(unstable)0.6-1.3medium578663
mod-gnutlssourcesqueeze0.5.6-1+squeeze2mediumDLA-170-1
mod-gnutlssourcewheezy0.5.10-1.1+deb7u1mediumDSA-3177-1

Notes

https://github.com/airtower-luna/mod_gnutls/commit/5a8a32bbfb8a83fe6358c5c31c443325a7775fc2

Search for package or bug name: Reporting problems