CVE-2015-2150

NameCVE-2015-2150
DescriptionXen 3.3.x through 4.5.x and the Linux kernel through 3.19.1 do not properly restrict access to PCI command registers, which might allow local guest OS users to cause a denial of service (non-maskable interrupt and host crash) by disabling the (1) memory or (2) I/O decoding for a PCI Express device and then accessing the device, which triggers an Unsupported Request (UR) response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3237-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1fixed
wheezy (security)3.2.96-2fixed
jessie3.16.51-2fixed
jessie (security)3.16.43-2+deb8u5fixed
stretch4.9.65-3fixed
stretch (security)4.9.30-2+deb9u5fixed
buster4.13.13-1fixed
sid4.14.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)3.16.7-ckt9-1medium
linuxsourcejessie3.16.7-ckt9-3~deb8u1mediumDSA-3237-1
linuxsourcewheezy3.2.68-1+deb7u1mediumDSA-3237-1
linux-2.6source(unstable)(not affected)

Notes

- linux-2.6 <not-affected> (xen-pciback introduced in 3.1)
http://xenbits.xen.org/xsa/advisory-120.html

Search for package or bug name: Reporting problems